Mainan Manokwari di ArchLinux

Hai sobat artemtech :D, kabarnya gimana nih, mudah-mudahan masih diberi kesehatan.. Beberapa waktu yang lalu, setelah berhasil memasang maleo html5 runner milik blankon di mesin arch linux, saya jadi penasaran, bisakah manokwari juga dijalankan di atas mesin ini?

Dari riset yang dilakukan, bersama pak rania dan bimbingan pak piko, alhamdulillah seminggu yang lalu manokwari sudah bertengger di mesin Arch linux, yeeah,, lets break the code 😀

“””
Pasang dahulu paket UNIQUE-3.0 (salah satu dependensi manokwari), karena di repo Archlinux tidak tersedia, KLIK DISINI
“””

1. persiapkan dulu perkakas – perkakasnya, yaitu dengan kloning dulu akun git repo manokwari:

$ git clone https://github.com/BlankOn/manokwari.git

2. masuk ke direktori manokwari:

$ cd manokwari

3. pasang dahulu paket-paket yang dibutuhkan, dengan perintah dibawah ini:

(manokwari)$ sudo pacman -Sy base-devel gnome-common glib2 gtk3 libwnck3 libgee vala gnome-menus libnotify 

update: paket webkitgtk didapat dari AUR melalui aplikasi yaourt, bukan webkit2gtk. webkitgtk adalah pengganti paket libwebkitgtk-3.0.0 di keluarga Debian. Berikut cara mendapatkan paket webkitgtk:

(manokwari)$ yaourt -Sy webkitgtk

4. Mengubah file konfigurasi paket untuk libgee

(manokwari)$ nano configure.ac

lalu cari baris berikut (baris 73):

... # baris 73
PKG_CHECK_MODULES(MANOKWARI, glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED gtk+-3.0 >= $GTK_REQUIRED atk >= $ATK_REQUIRED gee-1.0 >= $GEE_REQUIRED cairo >= $CAIRO_REQUIRED libgnome-menu-3.0 >= $LIBGNOME_MENU_REQUIRED libwnck-3.0 >= $LIBWNCK_REQUIRED unique-3.0 >= $UNIQUE_REQUIRED webkitgtk-3.0 >= $WEBKIT_REQUIRED x11 >= $X11_REQUIRED libnotify >= $LIBNOTIFY_REQUIRED)
... # baris 81
VALA_PACKAGES="--pkg atk --pkg x11 --pkg gdk-x11-3.0 --pkg gee-1.0 --pkg cairo --pkg gtk+-3.0 --pkg gio-unix-2.0 --pkg libgnome-menu-3.0 --pkg gdk-3.0 --pkg libwnck-3.0 --pkg unique-3.0 --pkg webkit-1.0 --pkg javascriptcore --pkg libsoup-2.4 --pkg libnotify"

ubahlah tulisan gee-1.0 >= $GEE_REQUIRED , menjadi gee-0.8 >= $GEE_REQUIRED dan tulisan --pkg gee-1.0 menjadi --pkg gee-0.8
secara lengkap, baris yang berubah akan menjadi seperti ini:

... # baris 73
PKG_CHECK_MODULES(MANOKWARI, glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED gtk+-3.0 >= $GTK_REQUIRED atk >= $ATK_REQUIRED gee-0.8 >= $GEE_REQUIRED cairo >= $CAIRO_REQUIRED libgnome-menu-3.0 >= $LIBGNOME_MENU_REQUIRED libwnck-3.0 >= $LIBWNCK_REQUIRED unique-3.0 >= $UNIQUE_REQUIRED webkitgtk-3.0 >= $WEBKIT_REQUIRED x11 >= $X11_REQUIRED libnotify >= $LIBNOTIFY_REQUIRED)
... # baris 81
VALA_PACKAGES="--pkg atk --pkg x11 --pkg gdk-x11-3.0 --pkg gee-0.8 --pkg cairo --pkg gtk+-3.0 --pkg gio-unix-2.0 --pkg libgnome-menu-3.0 --pkg gdk-3.0 --pkg libwnck-3.0 --pkg unique-3.0 --pkg webkit-1.0 --pkg javascriptcore --pkg libsoup-2.4 --pkg libnotify"

5. setelah itu, jalankan skrip autogen.sh:

(manokwari)$ sh autogen.sh

6. Jalankan make untuk kompilasi manokwari dan sudo make install untuk pemasangan di root

(manokwari)$ make
(manokwari)$ sudo make install

7. Lakukan pemindahan manual berkas “system” dan lakukan penambahan permission untuk sesi blankon.

(manokwari)$ sudo chmod +x /usr/bin/blankon-session
(manokwari)$ cd system
(system)$ sudo cp -R css fonts img js widget texture.jpg texture.xcf --target-directory=/usr/lib/manokwari/system

8. Selesai ^.^

di langkah 7, kita melakukan hal tersebut karena ada file2 di folder system yang tidak ikut disalin ke /usr/lib/manokwari/system, serta melakukan set permission setelah membuat file binary blankon-session yang semula saat melakukan compile, berkasnya masih belum executable
jika di langkah 7.1 tidak dijalankan, maka saat login screen tidak bisa di start manokwarinya
jika di langkah 7.2 – 7.3 tidak dijalankan, maka setelah login ke manokwari, tampilannya kacau (cuma file html nya saja yang dimuat, sedangkan css dan js yang mengatur desktop tidak dimuat karena memang tidak ikut tersalin saat setelah melakukan sudo make install)

manokwari murni setelah make install
manokwari sebelum menjalankan perintah 7.2
manokwari full
manokwari setelah menjalankan perintah 7.2

Oke itu saja dari saya, semoga manokwari bisa lebih baik lagi ^^. terima kasih sudah mampir, special tenks utk Rania Amina yg membantu dalam paket yang bentrok di arch linux

### updated 10-08-2017

Advertisements

3 thoughts on “Mainan Manokwari di ArchLinux

    1. maaf atas keterlambatan saya membalas komentar Anda. Paket webkitgtk adalah pengganti library libwebkitgtk-3.0.0 yang ada di keluarga Debian yang menangani gtk+-3.0. Sedangkan webkit2gtk adalah yang menangani gtk+-2.0.
      Yang dibutuhkan manokwari saat membangun paket adalah library libwebkitgtk-3.0.0 yang diwakili paket webkitgtk di keluarga ArchLinux. Paket webkitgtk bisa didapat dari AUR melalui aplikasi yaourt

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s